BT

如何利用碎片时间提升技术认知与能力? 点击获取答案

JRuby正式拥抱Java 5

| 作者 Werner Schuster 关注 6 他的粉丝 ,译者 Jason lai 关注 0 他的粉丝 发布于 2007年8月10日. 估计阅读时间: 1 分钟 | Google、Facebook、Pinterest、阿里、腾讯 等顶尖技术团队的上百个可供参考的架构实例!

先前我们已经报导过,JRuby团队最近在他们是否应当转向Java 5的问题上辩论不休。不过,据JRuby团队成员Ola Bini称,最终决定已经拍板定案

因此,通过在#jruby IRC频道的一些讨论,我们的核心团队决定在主干代码选择5+的路线。这样做的原因是,几乎每一个在Bug列表中回复的人都建议我们继续往前走,而Java 5的特性确实非常引人瞩目。

部分原因是可以使用新的语言特性来实现JRuby运行时。比如说,现在就用了Java 5标注(Annotations)来为方法绑定提供元数据。另一方面则是因为可以使用Java 5提供的并发库。JRuby 1.0提供了这些类库向旧版JRE的移植,但这些类库的移植版本无法带来Java 5等价类库所能带来的所有性能提升。

被限制在Java 1.4上的用户仍然是得到支持的,因为JRuby团队会构建出一个用Retroweaver处理过的版本,Retroweaver可以将Java 5的字节码导出成与Java 1.4虚拟机相兼容的类;另一个类似的工具叫做Retrotranslator。这两个工具在Java 5支持方面早就扬名已久,它们甚至允许标注等特性运行在Java 1.4平台上。

查看英文原文:JRuby targets Java 5

评价本文

专业度
风格

您好,朋友!

您需要 注册一个InfoQ账号 或者 才能进行评论。在您完成注册后还需要进行一些设置。

获得来自InfoQ的更多体验。

告诉我们您的想法

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我

JRuby 1.0仍然保持对1.4的支持 by Lai Jason

据Charles O. Nutter称,JRuby团队并不打算将1.0代码分支也移植到Java 5上,因此接下去要发布的1.0.1也是兼容1.4的。

Re: JRuby 1.0仍然保持对1.4的支持 by 田 乐

1.5的语法糖都没有修改虚拟机,所以用Retroweaver达到1.4支持就已经很OK啦!

Re: JRuby 1.0仍然保持对1.4的支持 by Zheng Ye

Annotation修改了class文件的格式。

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我

3 讨论

登陆InfoQ,与你最关心的话题互动。


找回密码....

Follow

关注你最喜爱的话题和作者

快速浏览网站内你所感兴趣话题的精选内容。

Like

内容自由定制

选择想要阅读的主题和喜爱的作者定制自己的新闻源。

Notifications

获取更新

设置通知机制以获取内容更新对您而言是否重要

BT