BT

如何利用碎片时间提升技术认知与能力? 点击获取答案

F#Tools 3.1.1增加对用于桌面和网络开发的Visual Studio 2013速成版的支持

| 作者 Anand Narayanaswamy 关注 0 他的粉丝 ,译者 李彬 关注 1 他的粉丝 发布于 2014年1月30日. 估计阅读时间: 3 分钟 | QCon上海2018 关注大数据平台技术选型、搭建、系统迁移和优化的经验。

已经发布的Visual F# Tools 3.1.1版本,将同时支持用于桌面和网络开发的Visual Studio 2013 速成版。用户还可以将它安装在没有Visual Studio的系统中。在后一种情况下,编译器、运行时以及F# Interactive将自动部署,而不会涉及到IDE工具。

微软的F#产品团队表示,现在已经实现了以上特性,以支持开发者在构建服务器和虚拟机的情境中使用F# 3.1。此外,开发者还能够在诸如Emacs和Xamarin Studio等编辑客户端中,使用F#的最新版本。

开发者可以直接在PowerShell会话中,使用如下命令,来自动完成F# Tools 3.1.1的安装:

$webclient = New-Object Net.WebClient
$url = 'http://download.microsoft.com/download/3/0/A/30A5D6DD-5B5C-
4E06-B331-A88AA0B53150/FSharp_Bundle.exe'
$webclient.DownloadFile($url, "$pwd\FSharp_Bundle.exe")
.\FSharp_Bundle.exe /install /quiet

微软预计将在即将发布的Visual Studio中提供F#工具。要安装Visual F# Tools3.1.1,开发者需要Windows 7或8之一,以及Visual Studio 2013旗舰版、高级版、专业版、用于桌面和网络开发的速成版。如果想要在没有Visual Studio的环境中安装该工具,开发者则需要安装额外的框架,例如MSBuild 12.0、.NET Framework 4.5.1和Windows 7/8.1 SDK。

安装完成后,开发者可以在Program Files(x86)\ Microsoft SDKs\F#\3.1\Framework\v4.0文件夹中找到所需的工具包中的DLL和EXE文件。

官方下载页面中,并未将Visual Studio 2012列为F# Tools 3.1.1的安装要求。它是否能够支持Visual Studio 2012还有待进一步了解。

查看英文原文:Visual F# Tools 3.1.1 Adds Visual Studio Express 2013 Desktop and Web Versions

评价本文

专业度
风格

您好,朋友!

您需要 注册一个InfoQ账号 或者 才能进行评论。在您完成注册后还需要进行一些设置。

获得来自InfoQ的更多体验。

告诉我们您的想法

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我
社区评论

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我

允许的HTML标签: a,b,br,blockquote,i,li,pre,u,ul,p

当有人回复此评论时请E-mail通知我

讨论

登陆InfoQ,与你最关心的话题互动。


找回密码....

Follow

关注你最喜爱的话题和作者

快速浏览网站内你所感兴趣话题的精选内容。

Like

内容自由定制

选择想要阅读的主题和喜爱的作者定制自己的新闻源。

Notifications

获取更新

设置通知机制以获取内容更新对您而言是否重要

BT