BT

SQL Server Express Shipping with Limited .NET 4.0 Support

by Jonathan Allen on Jan 23, 2010 |

With a recent update to Service Pack 1, Microsoft can now offer a version of SQL Server 2008 Express that runs with .NET 4.0 Beta 2. Previously users had to have .NET 2.0 SP2 or .NET 3.5 SP1 installed as a prerequisite. However, support is currently quite limited.

SQL Server 2008 Express can only host a single version of the CLR for the purpose of SQLCLR. To prevent introducing a breaking change, they are going to continue only support CLR 2.0. This means that even though you can install SQL Server Express with only .NET 4.0, you can’t use all of its capabilities. This includes built-in CLR types such as geometry, geography, and hierarchyid.

.NET 4.0 support has only been enabled on the runtime-only version of SQL Server Express. The other editions, SQL Server 2008 Express with Tools and SQL Server 2008 Express with Advanced Services, still require .NET Framework 3.5 SP1

For more information refer to Krzysztof Kozielczyk’s FAQ.

Hello stranger!

You need to Register an InfoQ account or to post comments. But there's so much more behind being registered.

Get the most out of the InfoQ experience.

Tell us what you think

Allowed html: a,b,br,blockquote,i,li,pre,u,ul,p

Email me replies to any of my messages in this thread
Community comments

Allowed html: a,b,br,blockquote,i,li,pre,u,ul,p

Email me replies to any of my messages in this thread

Allowed html: a,b,br,blockquote,i,li,pre,u,ul,p

Email me replies to any of my messages in this thread

Discuss

Educational Content

General Feedback
Bugs
Advertising
Editorial
InfoQ.com and all content copyright © 2006-2013 C4Media Inc. InfoQ.com hosted at Contegix, the best ISP we've ever worked with.
Privacy policy
BT