BT

Diffuser les connaissances et l'innovation dans le développement logiciel d'entreprise

Contribuez

Sujets

Sélectionner votre région

Accueil InfoQ Actualités PhoneGap 3.5.0 ne supporte plus iOS 5 et ne supportera pas WP 7

PhoneGap 3.5.0 ne supporte plus iOS 5 et ne supportera pas WP 7

Leia em Português

This item in japanese

Favoris

Cordova/PhoneGap 3.5.0 ne supporte plus iOS 5, la version 3.6.0+ ne supportera pas WP 7, et les mises à jour seront dans le futur délivrées par npm.

Construit sur la même version de Cordova, PhoneGap 3.5.0 a arrêté le support d'iOS 5. La raison principale en est que Cordova ne supporte que la version actuelle d'iOS ainsi que la version précédente, comme l'indique ce ticket. Cela signifie que l'iPad 1 n'est plus supporté car il ne peut être mis à jour avec iOS 6.

Un autre changement a été l'abandon du support pour les binaires arm64 iOS car Apple exige de ne fournir que des versions 32 bits pour les applications qui ciblent iOS 6. De plus, Xcode 5.0.1 et les versions suivantes génèrent à la fois des binaires 32 bits pour iOS 6 et des binaires 32 et 64 bits pour iOS 7.

Cette version de PhoneGap est la dernière à supporter Windows Phone 7.

La méthode recommandée pour installer PhoneGap n'est plus de télécharger l'archive mais d'utiliser npm. Toutes les plateformes ont reçu un fichier package.json de haut niveau et ont été chargées sur npm. Les mises à jours suivantes du framework seront livrées via npm au lieu de git.

Les notes de version complètes renferment des informations détaillées sur tous les changements amenés par cette nouvelle version.

Evaluer cet article

Pertinence
Style

Bonjour étranger!

Vous devez créer un compte InfoQ ou cliquez sur pour déposer des commentaires. Mais il y a bien d'autres avantages à s'enregistrer.

Tirez le meilleur d'InfoQ

Html autorisé: a,b,br,blockquote,i,li,pre,u,ul,p

Commentaires de la Communauté

Html autorisé: a,b,br,blockquote,i,li,pre,u,ul,p

Html autorisé: a,b,br,blockquote,i,li,pre,u,ul,p

BT